No announcement yet.

End of my rope w/ Comcast and port forwarding.

  • Filter
  • Time
  • Show
Clear All
new posts

    End of my rope w/ Comcast and port forwarding.

    Sorry for the wall of text, but I've been through a lot of iterations and want to make my situation as clear as possible.

    Been working on this problem for two days now without a working solution.

    Here's my network setup:
    Gateway is a SMCD3G-CCR currently in Bridge mode (according to Comcast)
    Router is a Netgear WNDR3300 w/ DD-WRT

    My goal is to open the ports required for Mumble and Source Dedicated Server, or get my computer into a DMZ to achieve the same.

    The beginning:
    Old network setup worked fine, with no open ports. Router was only device attached to the D3G-CCR, internet worked, I could access either the router just fine, and I could access the modem's options by switching my PC's ethernet cable to the modem's port.

    First, I enabled DMZ on my router - set to the static IP of my computer -

    No luck, all ports closed.

    After some research, I determined that my D3G-CCR was in routing mode and was applying its own firewall rules to my connection - so I enabled the modem's DMZ. I connected my PC directly to the modem and enabled DMZ on the modem's subnet - for my PC.

    No luck, all ports closed.

    Confused, I instead decided to call Comcast and have them bridge the modem's connection to my router - some googling lead me to the conclusion that this was the solution I needed. I unplugged my router from the modem and plugged my PC in, then called up Comcast and had them set to work.

    After a long and arduous phone call, the modem's settings were set, reset, changed around, and messed with remotely by Comcast.

    The modem booted up, and connected. Great, I thought, I'm done!


    I could not ping the modem. I could not reach its options page through its IP ( I did, however, have internet. My WAN and LAN IPs were now synchronized - the modem was no longer acting as a router and its subnet was disabled.

    Unfortunately....... the ports are still closed.

    At this point my helpful Comcast rep seemed to run out of steam - he had no idea why I couldn't ping or connect to the modem, nor had an answer as to why my ports were still closed.

    Thinking that perhaps I needed to re-introduce the router to the equation in order to finalize the network tree, I did so. First I reset DD-WRT to factory settings, then re-enabled DMZ to make sure it wouldn't block any connections.

    Ports still closed.

    That's where I stand - my PC connected through my default-settings (w/ DMZ) WNDR3300, and my D3G-CCR is acting as a bridge, inaccessible via web interface. My ports are still not opened. If I disable DMZ on my 3300 and set up port forwarding, there is no change.

    I'm at the end of my knowledge and experience, here. I don't know what else to try, what else to ask Comcast to do.

    Any help or advice would be greatly, hugely appreciated.

    Thank you for taking the time out of your day to help me out.
    2014 Mustang GT - Oxford White
    Track Pack | 301A | Borla S-Type | Lethal O/R/H | MGW Race-Spec | Eibach Prokit | AED Tuned
    2015 Ford Edge SEL 2.0 AWD - Wife's DD
    2015 Hyundai Sonata 2.0T Limited - DD

    I haven't played with DD-WRT for a while but the way most of the higher end routers seem to work (and DD-WRT is high end software) is that you have NAT port forwarding rules and the actual firewall rules as two separate entities. So it's not enough to just forward the ports you also need to make sure that the firewall itself is allowing those connections through. This COULD be different with a DMZ set up (the router software I have requires a dedicate interface for DMZ host) but would be worth looking into. Also see if you can figure out if Comcrap is blocking your ports as well, some ISPs will block certain ports to limit your traffic (for instance you can't run HTTP server on Optimum unless you get their Boost add-on). I know that CC is big into traffic shaping and could very well be the problem here.
    ScarFace88 - "So you're a dildo?"


      Have you tried using dmz AND port forwarding at the same time?

      Also does the DD-wrt show your internet address (mine is some isp router set to bridged, so my dd-wrt'd Netgear WNDR3700 is showing my internet address on the top right corner). to my knowledge if you don't see your internet address in the "wan IP" section, your connection isn't bridged to internet.

      On the other hand if the modem is bridged, you have to set up the address of the pc you are trying to control the modem, to the modems private lan address-segment so you can change anys ettings you want.

      PS. when i had to make my modem bridged, i had to disable nat on the modem too.
      Motives Of transport:
      Citro├źn DS3 vti 120 autom
      Honda NM4 Vultus

      Ford Fiesta SportVan

      Ds3 laptimes: Nordschleife 10:20,xx Ahvenisto: 1:50,72
      Join to the BCFHAS


        SMC makes shitty networking hardware.

        Regarding the actual issue; is your Netgear getting 67.162.6.XXX (or a comcast public IP) for the WAN address?