• The development of any software program, including, but not limited to, training a machine learning or artificial intelligence (AI) system, is prohibited using the contents and materials on this website.

Azureus problems


Sep 17, 2004
I know it's a little late now but here goes anyway.

Before I upgraded to everything was fine. Once I upgraded nothing worked. I got the 100% usage thing which I fixed by installing NOD32 2.5. Now it works well, it just won't download any faster than 20KBs, most of the time it is under 10 even...

The thing is, I dont know if it's Azuereus or the torrents themselves. I have Gumball 2004 torrent that downloaded very well up to the update and now it won't find even one seed or peer...

Anyone have any idea how to fix this? Should I go back to 2.2.something? BTW, where can I get the latest 2.2 before came out?

Also, can anyone post a random torrent that you know that downloads fast so I can see if its the torrents or Azuereus?

Thanks you

Edit: Forgot to say that Im using port 49173 but the default one (6881 I think) does the same.
Moving to the problems section ;)
What colour is the status circle next to the torrents?

(ps, i've been haveing loadsa crap with the new azareus too)
Most of the time they are either red or yellow but sometimes they will get blue and even green for some time, although they go back to being yellow or red later.
Thanks but I already have the ports set up on my firewall (just like it says in that link for my router). BTW, the link to your tracker in your signature doesnt work either and 6969 is forwarded as well...

Can anyone post a torrent that you know is downloading fast (around 100KBs+ if you can) so I can see if it is Azureus doing this?

Thank you
you dont have your firewall software blocking those ports? (and you dont need to forward port 6969 btw)
I dont have a software firewall... the only thing that I have is XP's firewall but it is turned off. I have a firewall in my router for my network. I forworded the ports that I wrote in my original post and set them up in Azureues and they checked out ok, but I cant download faster than 20KBs. Most of the time 10KBs.

It is set up exactly like I had it before the update to so I dont think its the ports or the firewall or anything to do with that. Although, I could at one point get your link to work (the one in your sig), that was before and after the update. Just now that I cant...
try setting the number of connections in az, i have found that the latest version can overload itself making connections and crash java or run into xp/osx limits.

The other thing to check out is the outbound connections try adjusting that value.

You dont mention what adsl speed you have but the configuration is relative.
Basically the new version is aggressive, you need to throttle it back to your connection, the previous versions seemed to stay more within the limits.

i have 512/128k connection, i use these settings
0 simultaneous outbound connections (connection tab in options)
5KB upload speed (transfers tab)
49KB/s download speed (transfers tab) (this is only used to set the speed lower than my max to allow browsing whilst downloading)
2 Upload slots per torrent
20 Max connections per torrent
0 Max connections globally

Now obviously these are not the best settings for everyone. Hell i tweak the damn things depending on the torrents im using.
But generally i find my torrents stay green and download.

(Course if anyone has a better setting let me know and i'll try it out)
I have a 1.5MBit down and either 128 or 96 up.

Im not going to limit my upload as that will give me even slower downloads (if it's even possible lol). My settings are similar to yours but not the same, I tweaked them with a guide I found on a torrents site.
I dont think it overloads XP by any means... now when I use it, it only uses about 5% max of pc usage..

Ill try installing and see what it will do.
Im not talking about the cpu usage, merely the connection limitations inherrent in the operating system. Especially since service pack 2. (Basically a kludge to stop xp propagating worms as quick)

The main reason for limiting your upload with torrents is to allow you to upload requests to the connections that you want to download from. If you are giving *all* of your bandwidth to them what do you get to use?

Think about when your trying to surf the net and you have a torrent maxing out your downloads..
My uploads don't get above 7-8 KB/s and if they do they are gone...

Ill try to limit what you said and I will tell you. Thanks
Dunno if you've done this already too, but update your Java to 1.5... :)
Ok, I tried a couple of things and nothing helped.

I do have Java 1.5 update 3... latest one on their website.

I uninstalled and installed or whatever the latest was before 2.3 and everything was the same. All my torrents would stay on yellow or red for the whole time and download at about 3 KB/s :x

After that I installed again and now there is an improvement. The torrents turn green (not for a second like before) but I am still downloading very slow, around 15 KB/s, although a big improvement...

In the settings page I changed the settings for 'Max number of connections per torrent' and 'max number of connections globally' to 0 (unlimited). I think this is what gave me the slight improvement but Im not sure.

Anyway, I think I am having a problem with the NAT or something that has to do with connecting to the tracker. Azureus shows that the average speed is xyz KB/s and Im only doing a little fraction of that.

I went to my router's settings and put my computer on the DMZ. Nothing changed, still slow speeds.

Anybody have any idea about this?

*Just a note, before I upgraded to 2.3 in the first place everything was fine. I was getting very good speeds...