Can't Download, no links, Error 403


New Member
Feb 27, 2012
Volvo V60, Ford Fiesta
As soon as I click on the link to the download side I get HTTP 403 Access denied. I haven't got that before.
Anyone know why
503 Error on the Zoink link for the 1080i version (their server down for maintenance). Otherwise no issues with any of the releases. Clear your cache and try again.
Everything is working fine for me. :?
Tried to erase the cache (IE9 cache) but no luck. Still 403.
If I use an anonymous internet server I get throug but the links get messed up. Same thing on all my computers.
Maybe your ISP is blocking it or something? Weird.
maybe peruse the FTP threads for an alternative?
I tried some different anonymous servers and the Torrage link worked.

It's strange, I don't know if the ISP is blocking it, then ISOhunt etc. should also be blocked....
Talked to my ISP and they do not block anything. The link-page works fine at work. So it has to be something with my Speedster Router or my F-secure.
Since F-Secure updated to 2012 it warns me about fragmented bla blah something when I use uTorren.
I solved it! Stupid F-Secure that resets the settings for web-safety when it's updated!!!!!
:dance: congratulations