D-Link router issues? Modem issues?

CrzRsn

Mr. Fedewhatever
DONOR
Joined
Mar 6, 2005
Messages
16,985
Location
Motor City, Michigan
Car(s)
13 Ford Mustang GT, 17 Ford Fiesta ST
So my home internet setup is a Netgear CM400 connected to a D-Link DIR-615 router. Periodically my internet completly shits the bed. No pages load, can't ping anything, nothing. Not on my laptop, not on my phones. Resetting the hardware via the gateway page doesn't seem to help. The only option is to physically unplug the router and modem for 10-20 seconds (I suppose I should see if resetting the router and not the modem would work to narrow down thr root cause). Almost as if the router just gets so loaded down with garbage that it stops working. Is this a possibility? Is it time for a new router and/or modem, or is it just Xfinity being shitty?
 

argatoga

Can't Start His Wank
Joined
Oct 4, 2005
Messages
17,963
Location
Seattle
Car(s)
'13 Moto Guzzi V7, '08 Pontiac Solstice GXP
If you have a spare PC pfsense is a good alternative as well.
 

CrzRsn

Mr. Fedewhatever
DONOR
Joined
Mar 6, 2005
Messages
16,985
Location
Motor City, Michigan
Car(s)
13 Ford Mustang GT, 17 Ford Fiesta ST

Perc

Very Odd Looking Vehicular Object
Joined
Mar 31, 2008
Messages
4,741
Location
Finland
Car(s)
4x4 diesel barge
DIR-615, isn't that over a decade old? I had a DIR-655 many, many moons ago. Time to upgrade?

If I needed a router today I would look at the Synology RT2600ac.
 

CrzRsn

Mr. Fedewhatever
DONOR
Joined
Mar 6, 2005
Messages
16,985
Location
Motor City, Michigan
Car(s)
13 Ford Mustang GT, 17 Ford Fiesta ST
i also had a load of trouble with my D-Link
and i installed this firmware: https://wiki.openwrt.org/toh/d-link/dir-615
been working like a charm ever since!!

EDIT: different setup for different versions! find yours in this list: https://wiki.openwrt.org/toh/start
Finally decided to try this and I think I bit off more than I can chew. Downloaded the file for hardware version I1. Followed the instructions to flash it to my router, but now I can't connect to it. I'm seeing conflicting instructions how to connect, but neither 192.168.1.1 nor 192.168.0.1 work. Tried both with the router in recovery mode. Get the message that the address took too long to respond each time. Can really use some help here please.

Following the top answer in this thread, and nothing https://superuser.com/questions/1070597/how-do-you-remove-dd-wrt-and-restore-to-factory-firmware-on-a-dlink-dir-868l

EDIT: Just realized thats for DD-WRT. Just tried the failsafe boot on the Open-WRT page, and still too long to respond.

EDIT2: Don't know what happened, but it suddenly started working. Got into the router can change settings. But now it can't connect to my modem.

EDIT3: Ok, managed to get the stock DLink firmware back onto the router and my home wifi is now working again. Not sure why Open-WRT was having so many issues. Maybe I'll try again at some time that isn't 11:30pm. Interestingly enough, when I flashed the DLink firmware back onto the device, it remembered all my settings/passwords/SSID/DNS from before. A bit surprised as I would've expected installing Open-WRT would have wiped all of that off, and the reinstall would've been totally clean.
 
Last edited:

bone

"bangle for president"
DONOR
Joined
Jan 14, 2004
Messages
16,373
Location
belgium!!
Car(s)
Volvo V40 & Yamaha Banshee
could this be your problem?

Go to 'http://192.168.0.1' from your PC web browser. (Note: most modern browsers don't work, see below for the details)


The firmware update system doesn't support the HTTP header Expect: 100-continue, which is used in POST requests by most modern browsers. If the browser sends this header, it will wait for the server to send a provisional response with status 100 Continue before sending the file contents. This feature was added in HTTP/1.1 to allow servers to reject uploads without needing to upload the file first. The router's built-in HTTP server claims to support HTTP/1.1, but it never sends the 100 Continue response so the browser waits forever or eventually times out.

Internet Explorer 6,7,8 on Windows, Firefox 13 Portable Edition on Windows 7, Google Chrome 49 on Windows 7 are known to work.

On GNU/Linux, Firefox 13.0.1 has happened to work. Problems have been reported with newer versions and most other browsers.

There seems to be some compatibility issues with the firmware update system network stack and at least Linux 3.5.3 and curl 7.27.0. Even forcing curl down to HTTP/1.0 resulted in a hang. One known working configuration is NetBSD 5.1.2 with curl 7.26.0. Downgrading curl to 7.26 on fresh version of GNU/Linux doesn't solve the issue.
i remember i struggled to get the firmware on the device as well, but iirc i had to use the TFTP protocol, but that isn't mentioned anywhere in the guide :dunno:
 
Last edited:

CrzRsn

Mr. Fedewhatever
DONOR
Joined
Mar 6, 2005
Messages
16,985
Location
Motor City, Michigan
Car(s)
13 Ford Mustang GT, 17 Ford Fiesta ST
I don't think that was the problem since eventually I was able to access the router.
 
Top