• The development of any software program, including, but not limited to, training a machine learning or artificial intelligence (AI) system, is prohibited using the contents and materials on this website.

ISP Blocking Port 6969 On Servers

?ric

New Member
Joined
May 1, 2004
Messages
8
Am I the only one whose ISP blocks port 6969? Back in the day these torrents used to reference multiple servers with different port numbers. Now thery're all running on the default port 6969 :(
 
try changing the port, 56560 is good.
 
Cruzz563 said:
try changing the port, 56560 is good.
I do run my client on a different port range (7890 to 8020). The tracker servers are the ones I can't connect to because they are running on port 6969.

For example new files look like this:

Code:
$ btshowmetainfo.py Fifth-Gear---2004.10.18.avi.torrent
btshowmetainfo 20030621 - decode BitTorrent metainfo files

metainfo file.: Fifth-Gear---2004.10.18.avi.torrent
info hash.....: 047912d32978ecb56d237aa06a24c52f1affe090
file name.....: Fifth Gear - 2004.10.18.avi
file size.....: 183013780 (698 * 262144 + 37268)
announce url..: http://gear.lettlurt.no:6969/announce
announce-list.: http://gear.lettlurt.no:6969/announce|http://bigfoot1942.weedns.com:6969/announce|http://bigfoot1942.sektori.org:6969/announce
comment.......: Fifth Gear - 2004.10.18 - More at http://gear.viper007bond.com/
Please seed (upload) for others when you are done downloading!
Notice the tracker port in this new torrent file is 6969 and is blocked by the ISP.

For comparison here's an old tracker file.
Code:
$ btshowmetainfo.py Top-Gear---2003.11.02.avi.torrent
btshowmetainfo 20030621 - decode BitTorrent metainfo files

metainfo file.: Top-Gear---2003.11.02.avi.torrent
info hash.....: 7deca7349e08d1b4a904377f3f0addf383227470
file name.....: Top Gear - 2003.11.02.avi
file size.....: 185436160 (707 * 262144 + 100352)
announce url..: http://66.90.73.130:2080/announce
announce-list.: http://66.90.73.130:2080/announce|http://66.90.73.120:6969/announce|http://67.18.44.198:2070/announce|http://67.18.44.194:2080/announce|http://66.90.73.127:2080/announce|http://66.90.73.134:2080/announce
comment.......: Top Gear - 2003.11.02 -- More at http://gear.viper007bond.com/
Notice the tracker port in this case was 2080. I was able to connect, download and share back then.
 
OK, if you use Azureus, you can use a proxy server for tracker communication.
open the configuration tab, go to "Server" (or the second from above if i translated it wrong.)

then "Enable Proxy" and enter the IP and portnumber of a working proxy.
to get those you can google for "free proxy list".
before you use it, try to use it with your browser first, and try to connect to http://gear.lettlurt.no:6969 .
if that works, you can use it with Azureus, and it should work.
 
This is entirely off-topic, but ?ric, is that Link in your avatar?
 
That's REALLY gay and weird that they block access to the port 6969 on servers. I've never seen that - only blocked ports on your connection.

Get a different ISP. :p

*hugs his ISP that has no caps or blocked ports really*
 
bigfoot1942 said:
then "Enable Proxy" and enter the IP and portnumber of a working proxy.
I never thought to try a proxy; didn't think it would work. Thanks for the advice. I use the BitTornado client from command line, no fancy GUI on the server I use.

I'll digress from the topic to better explain my ISP predicament.
------
Basically, if there is ever a contest for the most complicated download method I will win.

Satellite is the only available "broadband" service available where I live. The term broadband should be applied very loosely when discussing satellite since it hardly lives up to any real definition of the term. For whatever reason P2P programs flat out do not work over satellite. That reality combined with meager transfer allotments of 169 MB per 4 hour period rules out P2P via satellite. All this can be yours too for the rock bottom price of only $49.99/month + $25/month for a phone line. :shock:

I had two possible solutions to this situation. Either move my house about 1.5 miles down the road where DSL and cable are both available or use an external server. I chose ServerBeach since they have good transfer allotments of 1,000 Gigs / month and probably the only place that offers Debian Linux. The downside, that they never inform you of, is they are blocking certain ports. For some reason they won't divulge this top secret list of ports so you have to proceed until hitting a wall. I ran into this over a year ago when downloading Linux ISOs. It hasn't caused much grief since then until now.

Once I have the file downloaded to the external server I can proceed to download it to my home computer in chunks as the satellite transfer allotment will allow.

A pretty sad situation, isn't it? :x

While I'm off-topic...
Yes, that is Link in my avatar. I took it from the manual to the original game on the NES.
------

The proxy method is working, but transfer rates are much lower than normal. I'm getting between 3 and 30K/s. I noremally run around 500-700K/s. I'm not certain if this is a side effect of the proxy or if there just aren't enough seeders yet.

How much traffic has to go through the proxy? Is it just one initial contact or is there a constant flow of traffic between the client and tracker?
 
I'd move my house. :lol:

Assuming the clients aren't on 6969, only the tracker packets should have to go through the proxy, but everything may be going through it. Check your settings perhaps?
 
?ric said:
While I'm off-topic...
Yes, that is Link in my avatar. I took it from the manual to the original game on the NES.
You get a big thumbs up for that!
thumbs%20up%20banana.JPG

Long live the NES! :D
 
Viper007Bond said:
I'd move my house. :lol:

I had forgotten the third option to my broadband situation; you'll love this one. Adelphia was kind enough to offer to run cable 1.2 miles past about 25 neighbors to my house for the low, low installation fee of only $15,000. :roll:

I've figured out the proxy situation. I added the --ip option to the command line and that appears to have fixed it. The tracker was probably seeing the ip adddress of the proxy and giving that address to other clients. I'm back up and running now. :)
 
Top