Random Thoughts... [Automotive Edition]

Blind_Io

"Be The Match" Registered
DONOR
Joined
Apr 5, 2006
Messages
22,867
Location
Utah, Banana Republic
Car(s)
06 XTerra, '00 VFR800, '07 ST1300, '11 Multistrada

Hbriz

Ballroom Blitz
Joined
Jun 25, 2009
Messages
5,653
Location
Wollongong, Australia
Car(s)
'07 Megane dCi
The biggest problem I have with the McIntosh is the font the brand is written in. It sounds stupid, but when I was in a new Subaru Legacy with the McIntosh soundsystem, it just looked plain silly. It flashed up on the screen looking like some sort of ye olde fashioned pub or pirate ship themed restaurant.
 

Crazyjeeper

NickGyver
DONOR
Joined
Nov 29, 2006
Messages
7,984
Location
Dallas, TX
Car(s)
F150, CJ7, Mustang GT, Tenere, Griso
The biggest problem I have with the McIntosh is the font the brand is written in. It sounds stupid, but when I was in a new Subaru Legacy with the McIntosh soundsystem, it just looked plain silly. It flashed up on the screen looking like some sort of ye olde fashioned pub or pirate ship themed restaurant.

I can see that being a problem if they just put that font on for aesthetic reasons, but they didn't. All of their products have used that font for decades.

For example, here is a McIntosh MC75 tube monoblock amplifier which entered production in 1961.



Same font.
 

Hbriz

Ballroom Blitz
Joined
Jun 25, 2009
Messages
5,653
Location
Wollongong, Australia
Car(s)
'07 Megane dCi
It does not look out of place there, I wouldn't care if it were on my stereo at home for instance, but in the modern high-tech car interior, in amongst the sans-serif dashboard fonts and brushed aluminium look plastic, it looks like a terrible anachronism. And like most terrible anachronisms, it looks tacky.

I understand that it's tradition, but it doesn't change my opinion that it looks out of place in a modern car interior.
 
Last edited:

CAPT_Howdy

Forum Addict
Joined
May 24, 2008
Messages
5,192
Location
Hobb's End, New Hampshire
Car(s)
2004 Mazda6 Estate 3.0
The biggest problem I have with the McIntosh is the font the brand is written in. It sounds stupid, but when I was in a new Subaru Legacy with the McIntosh soundsystem, it just looked plain silly. It flashed up on the screen looking like some sort of ye olde fashioned pub or pirate ship themed restaurant.

It might look better in something like this:

 

AiR

Forum Addict
Joined
Dec 19, 2005
Messages
11,985
Location
Suecia
Car(s)
Bulgogi Knedliky 1.6 GDI (Hyundai i30)

katwalk

Forum Addict
Joined
Apr 1, 2008
Messages
10,342
Car(s)
2003 VW Beetle, 2017 Abarth Fiat 500c
My aunt needs a car so I linked many miatas. Let us hope she listens so I can borrow it. :D
 

The_Finn

Well-Known Member
Joined
Feb 7, 2005
Messages
4,565
Location
Worcestersheshershire MA
Car(s)
99 Volvo V70R
Guys, I have a big problem!

I test drove a blue S60R today at the dealership. OH MY GOD! This car absolutely blew my mind. The last reasonably fast car I drove was a new-ish 330i and it felt like a turd. You had to rev the nuts out of this thing to make it feel fast.

This Volvo had torque pretty much from idle. I never even floored and it still pulled me in the seat very hard. The sales rep had never actually been in the R and he was amazed how fast it was.

There were a few problems with this one though. It had the wrong transmission, and its price was too high. Yes, it only had 29k miles, but I can't afford to spend $25,000 on a car now.

The search continues for an early S60R with around 100k miles and preferably with orange seats and manual gearbox. I'm simply in love with this car.

the only issue with the S60R and V70R was the drivetrain tended to explode around 50-70K miles. Specifically the angle gear that transfers power to the rear. IIRC it wasn't even as a result of abuse (tho abuse helped it let go sooner) the part just tended to let go around the 50K mark (maybe 60K). I would definitely do some research to see if Volvo or anyone ever came up with a fix that wasn't "replace badly designed part with the same badly designed part rinse repeat" which was the only fix back when i was looking about a year or 2 ago.
 

JipJopJones

Well-Known Member
Joined
Aug 17, 2006
Messages
4,479
Location
North Shore
Car(s)
1979 Cressida Wagon, 1981 Corolla Hardtop
So the lease on my truck is ending soon. Need to find a replacement by the summer when I have a full-time job with commuting.

Are you wanting another truck? Or you could always do a lease buyout.
 

public

Volvomies, volvomies
Joined
Nov 26, 2007
Messages
11,911
Location
Causticity
Car(s)
P26L XC70 D5 and a ton of crap
Still looks like ye olde german beer.



(smoked beer, tastes like smoke, very weird)

Urbock is even smokier than M?rzen. Have some in my fridge, it's smoky as a Russian forest fire.
 

Blind_Io

"Be The Match" Registered
DONOR
Joined
Apr 5, 2006
Messages
22,867
Location
Utah, Banana Republic
Car(s)
06 XTerra, '00 VFR800, '07 ST1300, '11 Multistrada

katwalk

Forum Addict
Joined
Apr 1, 2008
Messages
10,342
Car(s)
2003 VW Beetle, 2017 Abarth Fiat 500c
for some reason it has no audio for me.
 

Blind_Io

"Be The Match" Registered
DONOR
Joined
Apr 5, 2006
Messages
22,867
Location
Utah, Banana Republic
Car(s)
06 XTerra, '00 VFR800, '07 ST1300, '11 Multistrada
Crapsicles. I have no idea what happened there, but it worked when I created the file.

I just tried to reupload the file but Windows Movie Maker keeps locking up.
 

Blind_Io

"Be The Match" Registered
DONOR
Joined
Apr 5, 2006
Messages
22,867
Location
Utah, Banana Republic
Car(s)
06 XTerra, '00 VFR800, '07 ST1300, '11 Multistrada
I just reuploaded the file, let's see if it works this time:

 

Blind_Io

"Be The Match" Registered
DONOR
Joined
Apr 5, 2006
Messages
22,867
Location
Utah, Banana Republic
Car(s)
06 XTerra, '00 VFR800, '07 ST1300, '11 Multistrada
Doesn't matter, the sound didn't work on that one either. It plays fine in Windows Live Movie Maker, but for some reason once it hits YouTube the sound is gone.

So far I haven't found a fix for it online, but I can't be the only one having this problem.
 
Top